EPOS4 EtherCAT Module EtherLab PDO파일 생성 관련



  • 안녕하세요, 중앙대학교 이동언 입니다.

    STEP-PC2를 사용해 EtherLab으로 PDO를 생성하려 하고 있습니다만 ESI 파일을 import 한 후에 

    Software Version : 0x0161

    Hardware Version : 0x6150을 Add device로 추가해줄시

    RxPDO에는 Controlword / ModesOfOperation

    TxPDO에는 Statusword / ModesOfOperationDisplay 

    각 2개씩만 추가되는것으로 확인 되고 있습니다.

    혹시 제가 모르는 상위버전의 NRMKECatTool 버전이 존재하는지요?

    만약에 그렇다면 기존 버전의 ECatTool은 어떻게 삭제하고 다시 넣어주나요?

    아니면 ECatTool에 호환가능한 EPOS4 Compact EtherCAT Module이 존재한다면 해당 ESI 파일 부탁드려도 되겠습니까?

    확인 부탁드리겠습니다.

    감사합니다.

    메일주소는 mistagom@cau.ac.kr 입니다.

      


     



  • @Dongun-Lee

    안녕하세요.

    먼저 사용에 불편을 드려서 죄송합니다.

    ESI 파일의 구성때문에 발생하는 문제로 고려되나 자세한 문제파악을 위해서 다음 3가지 파일을 송부해주시면 감사하겠습니다.

    1. ESI 파일

    2. NESI 파일 (현재 생성되는 해당 드라이브에 대한 RxPDO/TxPDO를 Domain에 모두 추가 후 "File -> Save -> NESI 파일로 저장")

    3. 생성된 c++ 프로젝트 파일

    위의 파일들을 다음의 이메일로 송부해주시면 최대한 빨리 문제를 파악해서 회신드리도록 하겠습니다 (Email: woongyong.lee@neuromeka.com).

    감사합니다.



  • 메일 송부해드렸습니다. 

    확인 부탁드리겠습니다.



  • @Dongun-Lee said:

    각 2개씩만 추가되는것으로 확인 되고 있습니다.혹시 제가 모르는 상위버전의 NRMKECatTool 버전이 존재하는지요?만약에 그렇다면 기존 버전의 ECatTool은 어떻게 삭제하고 다시 넣어주나요?아니면 ECatTool에 호환가능한 EPOS4 Compact EtherCAT Module이 존재한다면 해당 ESI 파일 부탁드려도 되겠습니까?확인 부탁드리겠습니다.감사합니다.

     Dear Dongun,


    Please find the latest ECatTool here at http://works.do/xuka73

    After generating EtherCAT C++ project, you will see the below successful message. Unless, please copy and send us the error message.



  • In addition, in order to compile XenomaiTest project in Eclipse, please follow the instructions at Neuromeka's document site.

    http://docs.neuromeka.com/2.3.0/kr/STEP/section2b/#build-example-project



  • @thach-do

    Thank you for your reply, the main problem that we are having is that when we try to create the RxPDO/TxPDO for these drivers, there are no necessary PDOs (ActualTor, TargetTor, etc.)

    For instance, if we are trying to use CST mode with EPOS4 Ethercat Module and click on the 0x1601 in the RxPDO Configuration, there are only 2 index.

    0x6040 Controlword and 0x6060 ModesOfOperation and no TargetTor, ActualTor, ActualPos, etc.

    Same applies for the TxPDO Configuration where there are only 0x6041 Statusword and 0x6061 ModesOfOperationDisplay.

    We have also tried the new EcatTool ver. 1.2.4, but only the image of the driver has changed, and not the PDOs.

    Could you double check on this issue?

    Thank you.

    P.S. We have solved the XenomaiTest project issue by following your manuals. Thank you.



  • @Dongun-Lee

    Thanks for your explanation.

    At first, please be sure that the EPOS4 supports torque-control mode. Then, you can add other objects (e.g. TarTor, ActTor, etc.) manually like below.

    Please note that some PDOs allow to add more objects but some PDOs do not. Ideally, it should be mentioned in the servo's manual. 



  • Add a new object into a PDO



  • I will try that method and get back to you shortly.

    Once again, thank you for your reply!



  • @thach-do

    Your solution worked perfectly, thanks for your help!

    There are two more questions that I would like to ask.

    1) Where can I set the OP mode of the drivers within the main.cpp (changing CST to CSP and vice versa).

    2) Is it possible to change the OP mode while the motor is running?



  • Hi,

    I will answer your 2 questions 

    1) Assume that you have already mapped entry ModeOfOperation (index of 0x6060), In your main.cpp you can see "ModeOfOperation" variable array, in order to change mode you can simply change value of that variable, e.g.  ModeOfOperation[0]=

    OP_MODE_CYCLIC_SYNC_TORQUE. In case you didn't map ModeOfOperation entry, you must use sdo write function to change the mode, we will have further support if this is your case.

    2. No, CiA402 compatible drivers don't allow changing operation mode online. You must set Servo-off first, then change operation mode and servo-on again. We have already provided functions to set servo on/off, you can check "setServoOn", "setServoOff" in "SystemInterface_EtherCAT_...h" file.



  • @Ho-Tam

    Thank you for your reply, we will try that method!


Log in to reply